配置rip实现小范围的通信
实验拓扑图:

pc的配置:

实验目的:
实现pc1、pc2、pc3、pc4之间互通信,可以互相ping通。
配置:
AR1:
1.先配置ip addr
2.配置rip
rip 1
version 2
[AR1]rip 1
[AR1-rip-1]version 2
[AR1-rip-1]network 192.168.1.0
[AR1-rip-1]network 192.168.2.0
[AR1-rip-1]network 1.0.0.0
[AR1-rip-1]dis this
[V200R003C00]
#
rip 1
version 2
network 192.168.1.0
network 192.168.2.0
network 1.0.0.0
#
return
[AR1-rip-1]
[V200R003C00]
#
sysname AR1
#
interface GigabitEthernet0/0/0
ip address 1.1.1.1 255.255.255.252
#
interface GigabitEthernet0/0/1
ip address 192.168.1.1 255.255.255.0
#
interface GigabitEthernet0/0/2
ip address 192.168.2.1 255.255.255.0
#
interface NULL0
#
rip 1
version 2
network 192.168.1.0
network 192.168.2.0
network 1.0.0.0
#
user-interface con 0
authentication-mode password
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#
return
AR2;
#
interface GigabitEthernet0/0/0
ip address 1.1.1.2 255.255.255.252
#
interface GigabitEthernet0/0/1
ip address 2.2.2.1 255.255.255.252
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
rip 1
version 2
network 1.0.0.0
network 2.0.0.0
#
AR3:
#
interface GigabitEthernet0/0/1
ip address 2.2.2.2 255.255.255.252
#
interface GigabitEthernet0/0/2
ip address 3.3.3.1 255.255.255.252
#
interface NULL0
#
rip 1
version 2
network 2.0.0.0
network 3.0.0.0
#
AR4;
#
interface GigabitEthernet0/0/0
ip address 172.16.1.1 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 172.16.2.1 255.255.255.0
#
interface GigabitEthernet0/0/2
ip address 3.3.3.2 255.255.255.252
#
interface NULL0
#
rip 1
version 2
network 3.0.0.0
network 172.16.0.0
#
实现效果图:
